#TECHNOLOGY#SECURITY#PROGRAMMING#NETWORKING#TEKNOPRENEUR

Alto ventos est coeptis utque fecit. Phoebe sine circumfuso arce. Tanto aliis. Matutinis cornua origo formaeque animal mundo. Chaos: fabricator. Natura mundo caesa addidit. Cuncta habendum meis omni ille formaeque emicuit septemque et. Lege fecit aethere porrexerat gentes horrifer formas.

Alto ventos est coeptis utque fecit. Phoebe sine circumfuso arce. Tanto aliis. Matutinis cornua origo formaeque animal mundo. Chaos: fabricator. Natura mundo caesa addidit. Cuncta habendum meis omni ille formaeque emicuit septemque et. Lege fecit aethere porrexerat gentes horrifer formas.

Alto ventos est coeptis utque fecit. Phoebe sine circumfuso arce. Tanto aliis. Matutinis cornua origo formaeque animal mundo. Chaos: fabricator. Natura mundo caesa addidit. Cuncta habendum meis omni ille formaeque emicuit septemque et. Lege fecit aethere porrexerat gentes horrifer formas.

Cisco IOS Command Line Interface Tutorial

Come on guys,let’s learn about Cisco ..

image

 

 

 

 

 

 

 

Pada kali saya akan menjelaskan CLI di cisco router.

For easier reference, saya tampilkan Table 1.

Cisco - IOS

 

 

 

 

 

 

As a security feature, Cisco IOS separates  dua bagian yaitu – user EXEC level and privileged EXEC level.

Pada  User EXEC level   hanya membolehkan acces  dengan jumlah terbatas hampir sama dengan user linux bukan root.
Pada Privileged EXEC level membolehkan acces ke perintah command router (dari password,konfigurasi,maintenance router dll)

berikut tampilan router cisco

Router> -> pada level user mode
Router# -> pada level priviledge mode

berikut cara perpindahan dari user mode ke priviledge mode

Router> enable
Password: [enable password]
Router# disable
Router>

While configure a cisco router,ada beberapa  mode acces yang digunakan ..

1. User Mode
2. Priviledge Mode
3. Config Mode
4. Interface Mode
5. line mode

berikut saya sertakan dalam gambar

Cisco - IOS Tutorial

bisa dilihat di table 2 IOS Command Prompt Summary dibawah ini  

Table 2 – IOS Command Prompt Summary

1

 

 

 

 

 

CLI editor features
Context Sensitive Help

This is a useful tool for a new user because at any time during an EXEC session, a user can type a question mark
to get help.perintah yang sangat membantu.

Router# co?
configure connect copy

atau bisa menggunakan perintah berikut..

Router# configure ?

memory             Configure from NV memory
network            Configure from a TFTP network host
overwrite-network  Overwrite NV memory from TFTP network host=20
terminal           Configure from the terminal
<cr>

Apabila perintah tidak di kenali akan terjadi error seperti berikut 

Router(config)#interface ethernat
^ % Invalid input detected at ‘^’ marker.

atau Command Abbreviation

cisco(config)#i
% Ambiguous command:  "i"

 

Table 3 – Summary Of Hot Keys
berikut  hot keys yang ada di SW dan Router Cisco 

Delete – Removes one character to the right of the cursor.
Backspace – Removes one character to the left of the cursor.
TAB – Finishes a partial command.
Ctrl-A – Moves the cursor to the beginning of the current line.
Ctrl-R – Redisplays a line.
Ctrl-U – Erases a line.
Ctrl-W – Erases a word.
Ctrl-Z – Ends configuration mode and returns to the EXEC.
Up Arrow – Allows user to scroll forward through former commands.
Down Arrow – Allows user to scroll backward through former commands

Berikut sample configuration dari  dari Router user mode,privilege,config mode dan kembali ke user mode.

Router> enable 
– switches to privileged EXEC level
Router# configure terminal – switches to global configuration level
Router(config)# interface ethernet0 – switches to configure the ethernet0 interface
Router(config-if)# no ip address – removes IP address
Router(config-if)# exit – exits back to global configuration level
Router(config)# exit – exits out of configuration level
Router# disable – disables privileged EXEC level
Router> 
prompt indicates user is back to user EXEC level

 

 

Jangan lupa ,for Saving Configurations your router
Router# copy running-config startup-config

melihat  the running-configuration,masuk terlebih dahulu ke privileged mode
Router#show running-config

melihat display the startup-configuration that is stored in NVRAM,masuk terlebih dahulu ke privileged mode
Router#show startup-config

berikut hasil  melihat show running-config

 

Current configuration:
!
version 11.2
!
hostname cisco
!
enable password cisco
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
!
interface Serial0
 ip address 20.2.2.2 255.0.0.0
!
router rip
 network 10.0.0.0
 network 20.0.0.0
!
ip route 0.0.0.0 0.0.0.0 20.2.2.3
!
line vty 0 4
 password telnet
 login
!
end

 

Displaying Software Version And More,menampilkan versi dari cisco dan ingin mengetahui lebih banyak informasi dalam IOS cisco.

versi cisco



Router# show version
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3640-J-M), Version 11.2(6)P, SHARED PLATFORM,
RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1997 by cisco Systems, Inc.
Compiled Mon 12-May-97 15:07 by tej
Image text-base: 0x600088A0, data-base: 0x6075C000

ROM: System Bootstrap, Version 11.1(7)AX [kuong (7)AX], EARLY DEPLOYMENT
RELEASE SOFTWARE (fc2)

Router uptime is 1 week, 1 day, 38 minutes
System restarted by power-on
System image file is "flash:c3640-j-mz_112-6_P.bin", booted
via flash
Host configuration file is "3600_4-confg", booted via tftp
from 171.69.83.194

cisco 3640 (R4700) processor (revision 0x00) with 107520K/23552K bytes
of memory.
Processor board ID 03084730
R4700 processor, Implementation 33, Revision 1.0
Bridging software.
SuperLAT software copyright 1990 by Meridian Technology Corp).
X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
TN3270 Emulation software.
Primary Rate ISDN software, Version 1.0.
2 Ethernet/IEEE 802.3 interface(s)
97 Serial network interface(s)
4 Channelized T1/PRI port(s)
DRAM configuration is 64 bits wide with parity disabled.
125K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)
Configuration register is 0x2102

Displaying Interface States
perintah show interface untuk  mendapatkan informasi yang sangat penting,beberapa diantara :

Interface State (e.g. UP, DOWN, LOOPED)
Protocol addresses
Bandwidth
Reliability and Load 
Encapsulation type
Packet Rates
Error Rates
Signaling Status (i.e. DCD,DSR,DTR,RTS,CTS)

 

Router#show interface serial 0
Serial0 is up, line protocol is down
Hardware is QUICC Serial
Internet address is 10.1.1.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation FRAME-RELAY, loopback not set, keepalive set (10 sec)
LMI enq sent 207603, LMI stat recvd 113715, LMI upd recvd 0, DTE LMI
down
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 1023 LMI type is CISCO frame relay DTE
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts
62856
Last input 1w, output 00:00:08, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/64/0 (size/threshold/drops)
Conversations 0/1 (active/max active)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 1000 bits/sec, 1 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1012272 packets input, 91255488 bytes, 0 no buffer
Received 916 broadcasts, 0 runts, 0 giants
18519 input errors, 0 CRC, 17796 frame, 0 overrun, 0 ignored, 723 abort
283132 packets output, 13712011 bytes, 0 underruns
0 output errors, 0 collisions, 31317 interface resets
0 output buffer failures, 0 output buffers swapped out
3 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

 

Welly Iskand
Instructors

How to configure UTP cable and RJ45

hi my friends,before we started how to configure UTP cable and rj45. today we learn something  about utp cable in english people known twisted pair cable.  😀
pada kali ini kita akan membahas tentang twisted-pair cables  dalam bahasa indonesia Kabel pasangan berpilin/berbelit.
kenapa harus berpilin/berbelit yah karena untuk menghindari gangguan gelombang elektromagnetik dari luar.

2013-04-25 10_56_41-Pasangan berpilin - Wikipedia bahasa Indonesia, ensiklopedia bebas

sebenarnya twisted-pair cables  ini terdapat dua tipe:

1. UTP cable  (Unshielded Twisted Pair) yaitu tidak memiliki selubung pembungkus.
2. STP cable (Shielded Twisted-Pair) yaitu memiliki selubung pembungkus. Fungsi selubung ini adalah pentanahan (grounding) untuk mengurangi lebih lanjut gangguan yang ada. Jadi jelas kabel yang memiliki selubung pembungkus akan lebih tahan terhadap gangguan dibandingkan yang tidak dibungkus.So that’s the difference … bisa kita lihat gambar dibawah ini

 

utp-and-stp

UTP cable  (Unshielded Twisted Pair)

sebuah jenis kabel jaringan yang menggunakan bahan dasar mentega tembaga, yang tidak dilengkapi dengan shield internal.
tidak ada pembungkus logamnya. Harganya lebih murah dibanding STP, dan biasa digunakan sebagai kabel jaringan telepon dan komputer.

Kabel UTP memiliki impendansi kira-kira 100 Ohm dan tersedia dalam beberapa kategori yang ditentukan dari kemampuan transmisi data yang dimilikinya seperti tertulis dalam tabel berikut.

2013-04-25 12_54_22-Pasangan berpilin - Wikipedia bahasa Indonesia, ensiklopedia bebas

 

 

 

 

 

 

 

 

Di antara semua kabel di atas, kabel Enhanced Category 5 (Cat5e) dan Category 5 (Cat5) merupakan kabel UTP yang paling populer yang banyak digunakan dalam jaringan berbasis teknologi Ethernet. dan sekarang populer juga untuk  Category 6 (Cat6).

Untuk pemasangan kable  UTP  ada dua tipe standard yaitu  EIA/TIA 568A & 568B Standard.
use the 568A standard on one end and 568B on the other end. 568A standard adalah standar international ,tapi bisa juga menggunakan 568B Standard. berikut  layoutnya:

Straight

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Crossover

 

 

 

 

 

 

 

 

Dalam menghubungkan jaringan Ethernet dengan menggunakan kabel UTP Category 5 atau 6, terdapat dua strategi pengabelan, yakni Crossover cable dan Straight-through cable. Kabel Crossover digunakan untuk menghubungkan perangkat komputer khususnya yang berhubungan dengan jaringan dengan device yang sama atau sejenis, seperti antara :

  • Switch to switch
  • Switch to hub
  • Hub to hub
  • Router to router
  • PC to PC
  • Router to PC

Sementara kabel Straight-through digunakan untuk menghubungkan Device yang berbeda. bisa lihat pada gambar dibawah ini.
2013-04-25 13_21_28-Crossover cable between a PC and a Router____ - The Cisco Learning Network

 

 

 

 

 

 

 

 

 

sebelum mulai terlebih dahulu sediakan alatnya diantaranya:
1.crimpting tool

2013-04-25 14_03_42-Google Image Result for http___www.harborfreight

 

 

 

2.lan tester bisa minjam bentar or beli…hehe
RJ45 Lan Tester
disini saya akan menjelaskan bagaimana memasangkan kabel utp sama rj45 secara client server secara standar,

Not Inter: *standar –> ph-h-o-b-bp-o-cp-c *inter[type CAT5 UP to 100 MHZ] –> ph-h-o-b-bp-o-cp-c

meaning :

po = putih orange
o = orange
ph = putih hijau
pb = putih biru
b = biru
h = hijau
pc = putih cokelat
c = cokelat
ph-h-o-b-bp-o-cp-c | Ujung A | | | | | | |Ujung B | ph-h-o-b-bp-o-cp-c

kabel pertama dan ujungnya harus sama susunannya,masukan perlahan ke rj45nya, jangan sampai tidak lewat ke lempengan tembaganya,setelah itu ditekan dengan crimpting tool sampai bunyi klik,lalu dicoba dengan lan tester. berikut testing lan tester.

on—-on
on—-on
on—-on
on—-on
on—-on
on—-on
on—-on
on—-on —>berhasil

on—-on
on—-on
on—-on
on—-on
on—-on
on—-on
on—-on
on—-off —->gagal,coba di cek lagi kabel ke delapan,di coba untuk di press lagi dan testing lagi.

berikut dapat dilihat dalam gambar

1

2

utp cable45

 

+-+-+-+-+-+-+-+-+-+-++-+-+-+-+

|P|o|w|e|r| |B|y| |g|s|o|f|t|l|a|b|s|
+-+-+-+-+-+-+-+-+-+-++-+-+-+-+

diolah dalam berbagai sumber

Intructors
Welly Iskand

IP ADDRESS v4 + SUBNETTING

#!ntr0#
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Setiap network interface yang terhubung kejaringan TCP/IP memiliki IP address yang unik.
IP address yang 32bit ini merupakan hal yang mudah diingat.
nama host (hostname) biasanya digunakan untuk mengingat suatu computer.
bagaimana kalo tidak ada hostname?? maka kita akan mengingat banyak angka ip address di seluruh dunia.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-==-

+let’s begin+

example: ketikan di web browser terserah mo pake apa,internet xplo or monzila or opera.
http://www.google.com
http://64.233.189.104

nah kedua alamat tersebut akan menghasilkan alamat yang sama,
perbedaannya www.google.com computer akan mencari ip address
terlebih dahulu dari comp host dengan nama wwww.google.com.
kalo ip address tidak.

disini saya tidak menjelaskan secara detail,silahkan cari banyak referensi

Format IP Address
-bentuk biner
ip address merupakan bilangan biner 32 bit
bentuk ip address adl sebagai berikut:
xxxxxxxx.xxxxxxxx.xxxxxxxx.xxxxxxxx

setiap simbol “x” dpt digantikan oleh angka 0 dan 1
mis:
10000100.01011100.01111001.00000001

nah.. notasi IP diatas tentu akan membuat kepala pusing dan puyeng serta akan susah dibaca.
jika dilihat dari bentuknya,IP Address terdiri dari 4 buah bilangan biner 8 bit.
nilai terbesar dari bilangan biner 8 bit 255.apabila diartikan dalam notasi desimal 8 bit
dibaca dari kiri ke kanan, [7p2+6p2+5p2+4p2+3p2+2p2+1p2+0p2]=8 bit p=pangkat

comp hanya mengenal hidup dan mati : o menandakan mati 1 menandakan hidup
10000100.01011100.01111001.00000001
maka didapat[7p2+2p2]+[7p2+4p2+3p2+2p2]+[6p2+5p2+4p2+3p2+0p2]+[0p2]
[132]+[92]+[121]+[1]

IP Address 132.92.121.1
untuk mempermudah proses pembagiannya maka,IP Address dibagi beberapa kelas.
IP address ini dikelompokan dalam lima kelas :kelas A :kelas B :kelas C :kelas D :kelas E
perbedaanya terletak pada ukuran dan jumlahnya.

IP Kelas A dipakai oleh sedikit jaringan namun jaringan ini memiliki anggota yang besar.
IP Kelas B biasanya dialokasi untuk jaringan berukuran sedang dan besar.
IP Kelas C dipakai oleh banyak jaringan,namun anggota jaringan masing-masing jaringan sedikit.
IP Kelas D&E Kelas D diperuntukan bagi jaringan multicast dan Kelas E untuk kepentingan experimental.
$Subnetting

setiap organisasi yang terhubung ke internet memperoleh sebuah network ID dari Internic
http://www.internic.net.
Network ID dari ini memiliki ukuran bermacam-macam,mulai dari kelas A,B,hingga kelas C.
ada beberapa alasan yang menyebabkan sebuah organisasi memerlukan lebih dari satu LAN agar dapat
mencakup seluruh organisasi,yaitu::
-Teknologi yang berbeda
-keterbatasn teknologi
-Kongesti pada jaringan
-Hubungan point -to- point

karena alasan-alasan diatas,network ID yang memiliki oleh suatu organisasi dipecah lagi menjadi
beberapa network ID lain dengan jumlah anggota jaringan yang lebih kecil.Teknik ini dinamakan
subnetting dan jaringannya dinamakan subnet (subnetwork).

Subnet Mask ialah angka biner 32 bit yang digunakan untuk:
=membedakan network ID dan host ID.
=menunjukan letak suatu host,apakah berada di jaringan lokal atau jaringan luar.
pada subnet mask,seluruh bit yang berhubungan dengan network ID di set 1.sedangkan bit yang berhubungan
dengan host-ID diset 0.

kelas IP subnet
Kelas A 11111111.00000000.00000000.00000000 255.0.0.0
Kelas B 11111111.11111111.00000000.00000000 255.255.0.0
Kelas C 11111111.11111111.11111111.00000000 255.255.255.0

subnet mask juga digunakan untuk menentukan letak suatu host,apakah dijaringan lokal,atau dijaringan
luar.hal ini diperlukan untuk operasi pengiriman paket IP.dengan melakukan operasi AND antara subnet
mask dengan IP address asal dan IP address tujuan,serta membandingkan hasilnya,dapat diketahui arah
tujuan paket paket IP tersebut.jika kedua hasil tersebut sama,maka host tujuan terletak diluar jaringan
lokal,sehingga paketpun dikirim kedefault router.

 

Referensi :
TCP/IP –Ono W Purbo-

instructor
Welly Iskand

how to enable ssh in centos 6

CentOS adalah sistem Operasi Linux,CentOS adalah singkatan dari Community ENTerprise Operating System, dikembangkan sebuah komunitas kontributor dan pengguna sistem operasi Linux. merupakan kembaran dari Red Hat Enterprise Linux (RHEL).

Dalam site  http://distrowatch.com/  CentOS berada urutan 11
distrowatch

fungsi enable ssh agar kita  dapat meremote server dengan packet data terenkrispsi, saya menggunakan Centos  6.3.terlebih dahulu pastikan ssh nya terinstall.

berikut topologinya

tpologi ssh

edit file menggunakan nano editor

#nano /etc/ssh/sshd_config

lalu edit  PermitRootLogin no ->user root tidak boleh untuk akses
PermitEmptyPasswords no ->tidak dibiarkan password kosong
PasswordAuthentication yes ->authentifikasi password dibolehkan

PermitRootLogin no
PermitEmptyPasswords no
PasswordAuthentication yes

silahkan lihat feature yang terbaru disini ->CentOS6.4

Instructor
Welly Iskand